My new AQ arrived last week and it was time to get it ready for action. Followed the step by step instructions and was ready for seasoning. Powered up just fine, probe indicator diplay was "OFF", pressed temp button, heard two beeps, set temp. Then pressed time and it does not give me the chance to change the time. I can press start and I see it defaulted to 2 hours, but I still can't increase or decrease the time. I've shut it down and I've not attempted the seasoning step. I would like to get this problem solved. I've been through the forum, but haven't seen a similar issue. I'm about ready to pull the back off to see what I can see. Any suggestions before I call Tony on Monday?
Original Post
Try pressing the time button in just a little bit longer say 3 to 5 seconds and then try to adjust the time up or down, hope this works for you before you call Tony.
Call Cookshack first before you use your smoker.If they determine the controller is defective, they may be able to send you a new one to install yourself. If so, be very careful removing the back panel-it is heavy and awkward to deal with. Also while inside, verify that the braided ground wire to your probe jack does not touch the end of the probe when plugged in.If it does, it will cause problems. Good luck!!
I know this may sound silly, but is the probe plugged in? I think that if the probe is plugged in you can't set the timer?
Just to close the loop on this issue. We determine the board was bad. Tony shipped me a new one, I installed it and everything seems to be working great. I seasoned it last night and expect to cook something more than wood this weekend. Thanks for the feedback.
Was the board easy to replace? Did you find any problem with your probe wiring inside? The Amerique is pricey, but as you found out the service from Cookshack is outstanding. Enjoy your smoker, they cook a mean brisket (full packer brisket,not just the flat).I've had mine since December, I love it!!
I had to replace a board a while back. It wasn't tough but one of the screw receptacles broke off. The board is o.k. with one less screw but I wasn't too pleased at the time.

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×