Hey to all,

Picked up an Amerique last week and got around to the "break-in" procedure. I've followed the instructions, set the temp and time. When I push the start button, nothing happens.

In the panel, next to the arrow that points left of the Start/Stop button is the word "service".

I notice when I switch to power button to ON there is a clicking sound. Is this normal?

Any help, comments, suggestions appreciated!

thanks in advance,

Bill
Original Post
I don't have a Amerique but a cs020 the clicking happens on mine when the element is cycling on and off.

What is the weather like where you are smoking? Does the element appear hot?

Will have to call customer service first thing in the morning, maybe some others with the Amerique will chime in a little later.
the clicking sound when you power on the switch is normal for the AmQ. I have never seen the "service" message. After powering on with the switch just push and hold down on the temp, time or probe buttons for a few seconds until you hear a beep; then push the up or down buttons to set. After every thing is set push the start/stop button; the message bord will then show the current temp of oven and probe (if used) and/or time remaining if probe is not used.
I do have everything set as you mentioned, temp and time. Then, when I pushd the start button, nothing happens......the message board shows nothing other than OFF in the top center and the word "service" in right center.

Thanks!
I'm good, sort of. I took it back and exchanged it. Got one that works well.....IF I can stop tripping the GFI!

any suggestions?

see ya!
Bill.

Call CS before you take it back. They actually could have solved the first problem I think, now you have a different issue.

They'll help isolate if its the unit or your plug.

Actually a GFI going out is the sign of a ground problem (that's what GFI's detect I believe)

It could be as simple as a bad GFI (once they trip, they're "technically" supposed to be replaced).

The first thing I'd do is test the unit on a non-GFI circuit.

You should also do a search on GFCI for some more info, there are 3 pages of info that might help educate you on the symptoms and fixes.
I did exchange it and the new one worked great on a non-GFI circuit. I guess I'm going to finally have to replace those tripped GFI plugs.

Now, what do I smoke first? A nice dilema, huh?

Thanks for all!
A butt is my favorite, but the rest of the crew says ribs. Any reason not to do both? Cook the butt to an internal temp and the ribs till they are done?

see ya
quote:

It could be as simple as a bad GFI (once they trip, they're "technically" supposed to be replaced).


Not true, in fact GFCI plug sockets have a test button on them that trips them to test to see if they are working correctly. GFCI's should be tested periodically.

Rich
quote:
Originally posted by rcspott:
Not true, in fact GFCI plug sockets have a test button on them that trips them to test to see if they are working correctly. GFCI's should be tested periodically.

Rich


That's what the city inspector said to a friend after they had an issue with one. He tried to make that same point about the buttons, but the inspector got into a lengthy discussion about electrical codes.

Why? because you don't know if the smoker tripped it or it's a faulty GFCI.

But the results above are the key point. When moved to a non GFCI it worked. That means either 1) the GFCI was bad or 2) there was a grounding issue in the smoker that doesn't show up on an non-GFCI plug.

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×