I brought the new to me FEC120 home and couldn't wait to turn it on and play with the settings. It has the IQ4 controller. So I cleaned out the fire pot. The previous owner had been using it up to the day he sold it to me so it needed a little cleaning but not much.

I set the cook temp for 224 and hit start. Within about 25 minutes it was chugging along but it was at 278. So I thought it might just be the start up and it would settle down. 30 minutes later it was now at 284. So I opened the door and let heat out and watched the temp drop to 180. Closed the door and 30 minutes later it was at 254. So I shut it down. Cleaned the inside a little bit and cleaned the temp probes. A couple hours later I clicked it on set it at 254. 30 minutes later it was at 278. So I turned it off and started hitting the forums looking for answers. I didn't really see what I was looking for so here is what I figured out.

It seems to overshoot the set temp and can't keep the fire going to drop the temperature so at it's lowest setting its just dropping too much pellets to drop the temp. I wish it had a LHT/HHT setting to play with.

So I tricked it. I set the temp for 224, when it overshot to 278 I opened the door and watched the temp drop below 224. Then I shut off the unit unplugged it, plugged it back in turned on the unit and set the temp for 224. This worked. Not positive why, but I think since there was a fire already going it didn't have any issues holding the set temp.

This doesn't explain why it overshoots. But I have tried it twice now, once with 224 and 250. Both times it worked.

I had a successful rib smoke and took them to the Metallica concert. Everyone loved them!

Any thoughts?
Original Post

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×