Skip to main content

This is the first issue I've had with the smoker since getting in for Christmas in 2020.

I'm trying to smoke some pork butts for the championship games tomorrow, but I can't get my SM066 to hold temp. When I turn the unit on, even with the probe disconnected, it says probe instead of time and the probe temp shows 200. This causes the smoker to hit DONE in just a few minutes and switch to hold mode at 140.

This means I can't smoke the butts even with a third party temp tool because the smoker won't maintain the temp reliably.

Here's what I've tried so far:

  1. Hairdryer to the probe connector
  2. Took the control box off and:
    1. Disconnected the probe from the controller board, but the probe still read 200.
    2. Unplugged the board from power, waited 30 seconds, and plugged it back in. I tried this with and without the probe connected to the controller.
    3. Used the hairdryer on the controller board for a good, long while.
    4. Took the controller out of the controller box completely to check the other side for debris. Saw none, but used the hairdryer to blow it off just in case.
  3. Power cycled the unit dozens of times
  4. Connected and disconnected the probe from the probe jack over and over again. Wiggled it too!

I'd really love to get this meat done for the game tomorrow so that we can feed our guests. Any suggestions?

Last edited by JeremySmokes
Original Post

Replies sorted oldest to newest

Just because I have no other ideas, please review the video.  I once made the error (ok, a couple of times), of not waiting for the beeps.  Since you said you pulled the controller and the board, the 066 manual cautions to make sure the polarity of the yellow wire in the controller is correct. Something to think about. This is a cook shack video. If this does not help, contact cookshack.

Add Reply

Link copied to your clipboard.