Skip to main content

Self started my fire pot as I always do, put the grates back on, flip the switch and set my temp and HHT. I noticed the fan didn't come on. So I turned it off and on again, still no fan. Well crap, now my lighting rod and my fan is out. Time to replace I thought. I got into the space by removing the 10 self tappers on the side of the smoker. HOLY CRAP! There was so much saw dust looking material. Piled 4 inches high on the piece just above the fan. So I vacuumed it all out. Flipped the switch and still no fan. Now I could actually see the fan not moving. Removed the fan housing and then removed the fan. Found the disconnect for the fan. Disconnected them and a bunch of dust fell out. Hmmm. I blew on it like we used to on the old Atari tapes. Like that ever worked. Plugged it back in, and wouldn't you know it the fan worked.

For about a second I pondered if I should go ahead and remove the lighting rod...then decided not. I was hungry and still had the cook to do that got delayed.

Just wanted to share because...

1. This might happen to you.

2. When you have a few minutes, open up the side panel where the 10 self tappers are. You might want to do a preventative cleaning.

Really not sure why there is sawdust. Probably some sort of grinding going on in the auger and this is where it falls.

One other note, I disconnected the lighting rod and blew on it...didn't work.
Original Post

Replies sorted oldest to newest

Add Reply

Link copied to your clipboard.