My smoker has been under cover for the winter and wanted to smoke today but it keeps blowing the GFCI fuse in my house. I have not had this problem before. After several attempts I've moved the pork butt to the oven but need suggestions on what to check. Once it cools I will look at the heating element to make sure its not loose. Anything else to check? When I removed the cover this AM the smoker was dry and no sign of moisture.
Original Post
I ran an extension cord into my house to another outlet and its now working. Must be a bad GFCI outletFrowner Oh well. I'll cook it in the oven today and get a new outlet installed. I'm running the smoker a bit on another outlet to make sure it stays on. I could smoke it this way but I don't want to leave my back door open all day because then I'm stuck at home baby sitting my home.
The new units blow GFI circuits cause of moisture in the units, then they work fine. Sitting idol all winter, the smoker may just have developed a lot of moisture. Run it on a non GFI circuit for one cook then see if it works fine on the GFI.
thanks. I ran it on the other outlet for a while and I also replaced the "bad" outlet. I retested and its now working fine so it was either I burned off the moisture or a bad outlet. Either way it was a cheap fix and its working now. I must say that this is one great smoker and I do love it.
I know that this is an old topic, but wanted to share my experience. Like the original post, my Cookshack was under a tarp all winter and kept tripping the GFI outlet on use. We removed the electronic 'head' from the cooker and used a blow dryer to dry out its interior and all of the various contacts. No moisture was visible, but it generally was damp under the tarp. Re-connected everything, and it runs as normal again. It seems that moisture likely was the issue.

We do not have any non-GFI outlets, so that was not an option.
If you continue to have issues you might remove the plastic control unit cover on top and look if moisture is in there. My cooker eventually stopped working. When I removed the cover I found that steam and smoke had been leaking up thru the metal cabinet into the area where the electronic control board was located. The board was corroded and I had to replace it. I removed the entire metal case and sealed certain areas where the steam could get thru. The biggest area of leakage is in the front on top of the door. The steam comes out of the door and leaks up into the top of the cabin. I have a thread on here somewhere I think.

Thank you for this thread. I had given up on my Cookshack smoker and am so glad I found this. My GFI outlet kept shutting off. I tried the blow dry in the circuit but I didn’t have any moister and so that didn’t net anything. I replaced the outlet today and success! 

Now back to smoking after 2 years of my smoker being out of commission thanks to a faulty outlet. 

Wow cool that you found my thread.  If it acts up again see my post above about removing the cover to where the control circuit board is (if you have the digital unit).

Thanks. Yeah I tried removing the digital unit and drying it before replacing the outlet. Anyway saved me a lot of trouble as I was starting to shop for something to replace my Cookshack which I love. It’s so easy and everything comes out great.

Add Reply

Post
×
×
×
×
Link copied to your clipboard.
×